LACP and Trunking Between Brocade FOS and Dell FTOS Switches


In this short lab I’ll demonstrate creating a LACP LAG and trunking between Brocade switches running FOS and Dell switches running FTOS. I utilize two Brocade 8000 switches [FOS 6.3], one Dell S60 switch [FTOS 8.3.3.8], and one Dell PowerEdge 2950 server with a QLogic QLE8242 CNA. Below is the network diagram for this lab.

Lab Network Diagram

Lab Network Diagram


You can see that the Dell PowerEdge 2950 server is on one end and the Dell S60 is on the other end, and there are two Brocade 8000s between them. I creata a LACP LAG between the two Brocade switches and trunk VLAN 6 and 7 over the link. I also create a LACP LAG between the ‘Star_Brocade_8000′ switch and the Dell S60 switch and trunk vlan 6 and 7 between them.


On the Dell S60, I give VLAN 6 an IP address of ’6.0.0.1/29′ and VLAN 7 an IP address of ’7.0.0.1/29′. Once all my configuration is done, I will test by pinging these IP addresses from the server. The server has a 2-port 10 GbE QLogic QLE8242 CNA installed. On the CNA, I tag one port in VLAN 6 and give it an IP address of ’6.0.0.2/29′ and tag the other port in VLAN 7 and give it an IP address of ’7.0.0.2/29′.


The reason I put the S60 at the end is because it’s an L2/L3 switch, and I can use it for testing connectivity via ‘ping’ from the server. The S60 has 48 x 1 GbE copper ports and also includes 4 x 1 GbE fiber ports (SFP) that can be used in place of the last four copper ports. I’ve installed the optional 2-port 10 GbE module (SFP+) so I can have 10 GbE connectivity connecting to the 10 GbE ports on the Brocade 8000.


The Brocade 8000 is a L2 converged switch capable of bridging between Ethernet and Fibre Channel via FCoE; it has 24 x 10 GbE fiber ports (SFP+) and 8 x FC ports (1/2/4/8 Gbps). Obviously, I’m not using the FCoE/FC capabilities in this lab. One important thing to keep in mind with this Brocade switch is that you have to use Brocade 10 GbE SFP+ optics for the Ethernet ports and Brocade 1/2/4/8G FC optics for the FC ports. You cannot use other vendor optics. If DAC cables are used, they must also be Brocade Active DACs.


Below is the configuration for each switch.


Hero_Brocade_8000

- cmsh
- conf t
- interface vlan 6
- exit
- interface vlan 7
- exit

- interface tengigabitethernet 0/2
- switchport
- switchport mode trunk
- switchport trunk allowed vlan add 7
- no shut
- exit

- interface tengigabitethernet 0/3
- switchport
- switchport mode trunk
- switchport trunk allowed vlan add 6
- no shut
- exit

- interface tengigabitethernet 0/0
- channel-group 5 mode active
- no shut
- exit

- interface tengigabitethernet 0/1
- channel-group 5 mode active
- no shut
- exit

- int port-channel 5
- switchport
- switchport mode trunk
- switchport trunk allowed vlan add 6-7
- no shut
- exit

- write memory
- end



Star_Brocade_8000

- cmsh
- conf t
- interface vlan 6
- exit
- interface vlan 7
- exit

- interface tengigabitethernet 0/0
- channel-group 5 mode active
- no shut
- exit

- interface tengigabitethernet 0/1
- channel-group 5 mode active
- no shut
- exit

- int port-channel 5
- switchport
- switchport mode trunk
- switchport trunk allowed vlan add 6-7
- no shut
- exit

- interface tengigabitethernet 0/2
- channel-group 6 mode active
- no shut
- exit

- interface tengigabitethernet 0/3
- channel-group 6 mode active
- no shut
- exit

- int port-channel 6
- switchport
- switchport mode trunk
- switchport trunk allowed vlan add 6-7
- no shut
- exit

- write memory
- end



Nebula_Dell_S60

- enable
- conf t
- interface range tengigabitethernet 0/48 – 49
- port-channel-protocol lacp
- port-channel 6 mode active
- no shut
- exit

- interface port-channel 6
- switchport
- exit

- int vlan 6
- ip address 6.0.0.1/29
- tagged port-channel 6
- no shut
- exit

- int vlan 7
- ip address 7.0.0.1/29
- tagged port-channel 6
- no shut
- exit

- write


Below you can see I am successfully able to communicate from the server to the Dell S60 switch.

Successful 'ping' test

Successful 'ping' test


Some interesting things to note:

- The default MAC aging timeout for both Brocade FOS and Dell FTOS switches is 300 seconds.


- Both switches have the same default VLAN – VLAN 1.


- On both switches, all ports are in a default mode in which they are neither L2 or L3 ports. To make a port an L2 port, you use the ‘switchport’ command and by default this will place the port in the default VLAN – VLAN 1.


-By default Brocade FOS switches run Rapid Spanning Tree Protocol (RSTP) whereas the Dell FTOS switches don’t have any Spanning Tree Protocol enabled by default; you can enable it if desired.


- Since the Brocade 8000 is a converged switch capable of carrying FCoE and bridging between Ethernet and FC, the MTU is set by default to baby jumbo frames: 2500 bytes; the Dell S60 sets the default MTU to the typical 1554 bytes.


- The Brocade 8000 switch supports the following trunk types:
• Static, standards-based LAG.
• Dynamic, standards-based LAG using LACP.
• Static, Brocade-proprietary LAG.
• Dynamic, Brocade-proprietary LAG using proprietary enhancements to LACP.


- The Dell S60 supports the following trunk types:
• Static, standards-based LAG.
• Dynamic, standards-based LAG using LACP.


- On the Brocade 8000, you can configure a maximum of 24 LAGs with up to 16 links per standard LAG and four links per Brocade-proprietary LAG.


- On the Dell S60, a maximum of 128 LAGs with up to 8 links per LAG is possible.


Of course, in this lab, I just used whatever switches I had on hand to demonstrate Brocade FOS and Dell FTOS interoperability. For an advanced 10 GbE converged switch from Dell, one would choose the Dell S5000 switch. The Dell S5000 is a modular L2/L3 switch which supports both Ethernet (1/10 GbE) and FC (2/4/8G) modules (12 ports each). A module can be inserted in up to four bays for a total of 48 ports. 4 x 40 GbE fixed ports which can each be broken out into 4 x 10 GbE are also provided. To learn more about the Dell S5000 see one of my prior blogs: Dell Networking S5000: Deployment of a Converged Infrastructure with FCoE.

Twitt

Tags: , , , , , , , , , , , , , , , , , , , , , , , , , , , , , , , , , , , , , , , , , , , ,

Leave a Reply

*


+ four = 5