Deploying a Dell PowerEdge M1000e Chassis with Dell Blade Servers and Dell MXL Blade Switches


In this blog I demonstrate how to setup a Dell M1000e chassis with a Dell PowerEdge M620 server and two Dell MXL blade switches [FTOS 8.3.16.2]. The Dell M1000e chassis is part of a larger network composed of three Dell S4810 switches [FTOS 9.1]. Windows Server 2008 R2 Enterprise is installed on the server. Below is the network diagram for this lab.

Lab Setup with Dell PowerEdge M1000e Chassis and MXL blades

Lab Setup with Dell PowerEdge M1000e Chassis and MXL blades

The Dell PowerEdge M620 blade chassis I am using is in slot 9 of the Dell M1000e PowerEdge chassis. On the server, I have a Broadcom 57810S CNA on the Fabric A slot, so the first 10 GbE port on the server is going to internal port ‘te 0/9′ on ‘Dell_MXL_A1′ and the second 10 GbE port is going to internal port ‘te 0/9′ on ‘Dell_MXL_A2′. Below I display a snapshot of the ‘Network Connections’ view in Windows Server 2008 Enterprise R2. As you can see, there are two connections (one for each port on the Broadcom 57810S CNA).
'Network Connections' view in Windows Server 2008 R2 Enterprise

'Network Connections' view in Windows Server 2008 R2 Enterprise

Below I confirm the I/O Fabric Interfaces available via the ‘Chassis Management Controller’ (CMC) GUI. As you can see, only Fabric A has an adapter installed.

Chassis Management Contoller View of Fabric I/O Interfaces

Chassis Management Contoller View of Fabric I/O Interfaces

For this example lab setup, the Dell MXL blade switch configuration is very simple. The MXL blades are in slots ‘A1′ and ‘A2′ on the Dell PowerEdge M1000e chassis. I stack the MXL switches and put each respective port ‘te 0/9′ and ‘te 1/9′ in layer 2 mode via the ‘switchport’ command and enable it via the ‘no shutdown’ command. The port(s) then become part of the default VLAN, ‘VLAN 1′. I do the same for ports ‘fo 0/33′ and ‘fo 1/33′ connecting up to the Dell S4180 switches. Here, the MXL switch is being used simply as a pass-through layer 2 switch.


Next, I put ‘fo 0/52′ and ‘fo 1/52′ in a VLAN and give it an IP address as shown below. I also give each respective port connecting up to the ‘Dell_S4810_Core’ a unique IP address in the ’20.0.0.0/24′ subnet. Lastly, I enable OSPF on both ‘Dell_S4810_A1′ and ‘Dell_S4810_A2′. Since OSPF is already enabled on ‘Dell_S4810_Core’ with the correct configuration, the loopback IP addresses (’30.0.0.1/24′ and ’40.0.0.1/24′) will be reachable by the server. We will test this later.


Dell_S4810_A1

- enable
- conf
- stack-unit 0 priority 2
- stack-unit 0 stack-group 1
- exit
- wr
- reload

- enable
- conf
- int te 0/52
- sw
- no shut

- int vlan 5
- ip address 5.0.0.1/24
- untagged fo 0/52
- vrrp-group 5
- virtual-address 5.0.0.1
- no shut

- int fo 0/48
- ip address 20.0.0.2/29
- no shut
- exit

- router ospf 1
- router-id 2.2.2.2
- network 20.0.0.0/29 area 0
- network 5.0.0.0/24 area 0
- end
- wr



Dell_S4810_A2

- enable
- conf
- stack-unit 0 priority 1
- stack-unit 0 stack-group 1
- exit
- wr
- reload

- enable
- conf
- int te 0/52
- sw
- no shut

- int vlan 5
- ip address 5.0.0.2/24
- untagged fo 0/52
- vrrp-group 5
- virtual-address 5.0.0.1
- no shut

- int fo 0/60
- ip address 20.0.0.3/29
- no shut
- exit

- router ospf 1
- router-id 3.3.3.3
- network 20.0.0.0/29 area 0
- network 5.0.0.0/24 area 0
- end
- wr


Now I NIC team the ports on the Broadcom 57810S adapter via LACP and give the virtual adapter and IP address of ’5.0.0.3/24′.


Note below I can ping the ’5.0.0.1/24′ virtual IP address. I can also ping both loopback IP addresses on ‘Dell_S4810_Core’ (’30.0.0.1/24′ and ’40.0.0.1/24′) at the same time. If you take a look at the bytes sent/received statistics on each interface, you will see the adapter uses one port to ping to one IP address destination and the other port to ping to the other IP address destination.

Pinging virtual IP address, '5.0.0.1/24', from the Dell m620 blade server

Pinging virtual IP address, '5.0.0.1/24', from the Dell m620 blade server


Pinging both 'Dell_S4810_Core' loopback addresses from the Dell m620 blade server

Pinging both 'Dell_S4810_Core' loopback addresses from the Dell m620 blade server


Twitt

Tags: , , , , , , , , , , , , , , , , , , , , , , , , , , , , , , , ,

One Response to “Deploying a Dell PowerEdge M1000e Chassis with Dell Blade Servers and Dell MXL Blade Switches”

  1. Jon C says:

    Say. Were there any other specific settings that you had to set on the switchport. Mine still doesn’t work.

Leave a Reply

*


eight − = 3