Cisco vPC with Dell S4810 at ToR


Cisco’s vPC technology is similar to Dell’s VLT; it enables an access/leaf switch or server to have single LAG connecting up to two separate switches. This allows for an non-blocking, multipathing scenario. You can read more about Dell’s VLT technology and its advantages on my prior blog, Dell Force10 – Layer 2 Multipathing via Virtual Link Trunking (VLT) In this blog, I will configure Cisco vPC between two Cisco Nexus 5548UP switches [NX-OS 5.1(3)N2(1)] down to a third ToR Cisco Nexus 5548UP switch [NX-OS 5.1(3)N2(1)]. I will then replace the third Cisco Nexus 5548UP switch at ToR with a Dell S4810 switch [FTOS 9.0].


The first topology diagram is shown below. You can see the Cisco vPC is used from the two core Nexus 5548UP switches down to the ToR Cisco 5548UP switch. I also use 1000Base-T SFP transceivers to convert the Dell S4810 fiber ports to copper, so I can connect it to the management port of the Cisco Nexus.

Cisco vPC down to ToR Cisco Nexus 5548UP

Cisco vPC down to ToR Cisco Nexus 5548UP


The respective configuration is shown below.


Cisco_Nexus_5548UP_1

- conf
- feature vpc
- feature lacp

- int mgmt 0
- ip address 10.11.129.238/20
- exit

- vrf context management
- ip route 0.0.0.0/0 10.11.129.254
- exit

- vlan 100
- exit

- vpc domain 1
- role priority 1
- peer-keepalive destination 10.11.129.239
- exit

- interface ethernet 1/17-18
- switchport mode trunk
- channel-group 1 mode active
- exit

- interface port-channel 1
- switchport mode trunk
- spanning-tree port type network
- vpc peer-link
- exit

- interface Ethernet1/13
- switchport mode trunk
- channel-group 10 mode active
- exit

- interface port-channel 10
- switchport mode trunk
- vpc 10
- exit

- copy running-config startup-config



Cisco_Nexus_5548UP_2

- conf
- feature vpc
- feature lacp

- int mgmt 0
- ip address 10.11.129.239/20
- exit

- vrf context management
- ip route 0.0.0.0/0 10.11.129.254
- exit

- vlan 100
- exit

- vpc domain 1
- role priority 100
- peer-keepalive destination 10.11.129.238
- exit

- interface ethernet 1/17-18
- switchport mode trunk
- channel-group 1 mode active
- exit

- interface port-channel 1
- switchport mode trunk
- spanning-tree port type network
- vpc peer-link
- exit

- interface Ethernet1/13
- switchport mode trunk
- channel-group 10 mode active
- exit

- interface port-channel 10
- switchport mode trunk
- vpc 10
- exit

- copy running-config startup-config



Cisco_Nexus_5548UP_3

- conf
- feature lacp
- interface ethernet 1/17-18
- switchport mode trunk
- channel-group 10 mode active
- exit

- copy running-config startup-config


I confirm that the vPC is correctly configured and functional with the below commands.

Cisco_Nexus_5548UP_1 - 'show vpc brief' output

Cisco_Nexus_5548UP_1 - 'show vpc brief' output

Cisco_Nexus_5548UP_2 - 'show vpc brief' output

Cisco_Nexus_5548UP_2 - 'show vpc brief' output

Cisco_Nexus_5548UP_1 - 'show vpc statistics vpc 10' output

Cisco_Nexus_5548UP_1 - 'show vpc statistics vpc 10' output

Cisco_Nexus_5548UP_2 - 'show vpc statistics vpc 10' output

Cisco_Nexus_5548UP_2 - 'show vpc statistics vpc 10' output

Cisco_Nexus_5548UP_3 - 'show interface port-channel 10' output

Cisco_Nexus_5548UP_3 - 'show interface port-channel 10' output


Now I replace the ‘Cisco_Nexus_5548UP_3′ ToR switch with a Dell S4810 and confirm all is still functional. The new diagram is below.

Cisco vPC down to ToR Dell S4810

Cisco vPC down to ToR Dell S4810


The configuration on the Cisco Nexus 5548UP switches configured with vPC remain the same. The Dell S4810 configuration is below.


Dell_S4810

- enable
- conf
- interface tengigabitethernet 0/20
- port-channel-protocol lacp
- port-channel 10 mode active
- no shutdown
- exit

- interface tengigabitethernet 0/22
- port-channel-protocol lacp
- port-channel 10 mode active
- no shutdown
- exit

-interface port-channel 10
- portmode hybrid
- switchport
- no shut
- exit

- int vlan 100
- tagged port-channel 10
- exit

- wr


Note, on the Dell S4810, I have to explicitly state what VLANs to send on the trunk link whereas on the Cisco Nexus switches it defaults to send all VLANs. I confirm all is good via below commands.

Cisco_Nexus_5548UP_1 - 'show vpc brief' output

Cisco_Nexus_5548UP_1 - 'show vpc brief' output

Cisco_Nexus_5548UP_2 - 'show vpc brief' output

Cisco_Nexus_5548UP_2 - 'show vpc brief' output

Dell_S4810 - 'show interfaces port-channel 10' output

Dell_S4810 - 'show interfaces port-channel 10' output


Twitt

Tags: , , , , , , , , , , , , , , , , , ,

3 Responses to “Cisco vPC with Dell S4810 at ToR”

  1. John Heyer says:

    Nice post. Do you know what the “portmode hybrid” command on the Port-Channel interface means? It seems to be the only option, but doesn’t show up in my config. I have a few S4810s running 9.1 or 9.2

  2. Humair says:

    Hi John,

    The “portmode hybrid” command allows both tagged and untagged traffic to be carried over a trunk link. You can have multiple trunk links and have a different untagged or ‘native’ VLAN for each trunk. You must enable “portmode hybrid” before making the port a layer 2 port with the ‘switchport’ command. Remove all configuration from the port, put it in “portmode hybrid” and then make it a layer 2 port with the ‘switchport’ command and put all your configuration back. The “portmode hybrid” command should display under the interface in the ‘running-config’.

  3. Marino says:

    Hey Humair,

    I tested this exact same scenario and what I found weird was that if I use LACP on the S4810 downstream switch, the port-channel shows as down on the S4810 side, but up on the Nexus vPC peers. If I reboot the S4810, the vPC peers report as down, and then go back up after the 4810 comes back up.

    If I switch from LACP to a static LAG, everything reports as up on both sides.

    Any thoughts as to why this might happen?
    FTOS = 9.1.0.0
    NX-OS = 5.1(3)N1(1a)

Leave a Reply

*


− four = 1